: 4582 | 108668 | 12353

Select target version for Notes application 
Use this IdeaSpace to post ideas about Domino Designer.

: 17
: 20
: 3
: Domino Designer
: database, application, version
: Karl-Henry Martinsson1597 06 Dec 2007
:
: / Email

I am sure I am not the only one that is, or in the future will, be developing applications in a mixed-client environment. Today some (most) of our users are on R5, while other are running Notes 7.0.
If I would use Domino Designer 7, I might introduce some code that won't work in R5. Or write a function in R5 that is built-in in Notes 7. One example: long ago, I wrote a function called split(). Now that function is built-in into the language. Today I used the Domino 7 client to do a  "recompile all", since my script librarys went out of sync. 
Of course it protested when the compiler encountered sync() in my code.

What I would like to be able to do is to set a database (sorry, "Application") property, called for example "Notes Target Client version". If I set it to "5.0", I will, when I write my scripts, not have access to, or get a warning, if I use functions that does not exist in R5. This way I could use the latest designer, with all the new features, but still produce R5 code.

Personally I think this would be a great feature. To expand on the idea, the setting could also apply to views (If the db is set to R5, and I create a column with "use value as color", I should get a warning, saying "this column will not show up/work in R5, only in 6.0 and higher". Same thing with other design elements.




1) Rob Goudvis6585 (07 Dec 2007)
I would prefer an environment that let you easily install more than one version of the Notes Client/Designer. The differences between versions are not limited to script code. Therefor it would be better to use the correct environment for a specific application.

Currently it can be done to install more than one version, but you need to modify the Registry contents when you install both a R6 and R7 (or R8) Notes environment.
2) Karl-Henry Martinsson1597 (10 Dec 2007)
@1: What about the poor developer that is still on R5, but need "Recompile all Lotusscript" that came in Domino Designer 6? Or if I need/want to use some other function in the Designer that is not available in the earlier version? Not a language function, but things like recompile all, better debugger, etc.
I know you can install several different versions on the same computer, but you are still limited to what that version of Domino Designer can do.
The whole idea is that you get the power of the latest version of Designer, but don't risk using functions that are unavailable in the target version, or naming your own functions/subs the same as functions built-in to later versions...










:
:




Welcome to IdeaJam™


You can run IdeaJam™ in your company. It's easy to install, setup and customize. Your employees, partners and customers will immediately see results.

Use IdeaJam to:

  • Collect ideas from employees
  • Solicit feedback and suggestions from employees and customers
  • Run innovation contests and competitions
  • Validate concepts
  • Use the power of "crowd-sourcing" to rank ideas and allow the best ideas to rise to the top

IdeaJam™ works with:

  • IBM Connections
  • IBM Lotus Quickr
  • Blogs and Wikis
  • Websphere Portal
  • Microsoft Sharepoint
  • and other applications.

IdeaJam has an extensive set of widgets and API's that allow you to extend and integrate IdeaJam™ with other applications.

Learn more about IdeaJam >>






IdeaJam developed by

Elguji Software Logo